====== Technical Information: OpenIndiana Topics ====== [[:tech:openindiana:illumos:start|IllumOS Topics]] \\ [[:tech:openindiana:userland:start|oi-userland]] ===== Common Tasks ===== ==== Basic Installation ==== For VirtualBox guest installation, install the Solaris Guest Additions: ''pkgadd -d ./VBoxSolarisAdditions.pkg'' Enable DNS: add "dns" to the ''hosts'' line in ''/etc/nsswitch.conf'' ==== Common Admin Tasks ==== === Services === * Check the dependents of the service: ''svcs -D //servicename//'' * Enable a service: ''svcadm enable //servicename//'' * Enable dependencies of a service: ''svcadm enable -r //servicename//'' * Verify a service has been enabled: ''svcs -x //servicename//'' * Restart a service: ''svcadm restart //servicename//'' * Enable a service temporarily (or in single-user mode): ''svcadm enable -rt //servicename//'' \\ // This will enable service with its dependencies for current session, not persisted across reboots // * Disable a service: ''svcadm disable //servicename//'' === Services in maintenance state === Normally, when a service instance is in a maintenance state, all processes associated with that instance have stopped. However, you should make sure before you proceed. Determine why the service is in maintenance: ''svcs -x //servicename//'' * Consult the log file or man page mentioned to determine what the error is. * Determine if any process that are dependent to the service have not stopped. The following command lists all of the processes that are associated with a service instance as well as the PIDs for those processes: \\ ''svcs -p //servicename//'' //(Optional)// Kill any remaining processes ...repeat this step for all processes that are displayed by the svcs command: \\ ''pkill -9 process-name'' Restore the service: ''svcadm clear //servicename//'' ===== Zones ===== ==== Basic ==== Here's a decent guide: [[http://wiki.openindiana.org/oi/Building+with+oi-build|building in a zone]] == Create ZFS pool for zones === * List of disks: ''echo | format'' // (look for disk and name) // * ''zpool create poolname diskname'' \\ // eg. ''zpool create zonepool c2t1d0'' // * Create ZFS filesystems for zone: zfs create -o compression=on -o mountpoint=/zones zonepool/zones zfs create -o sync=disabled -o atime=off zonepool/zones/oidev * Create zone configuration: \\ // (remember NIC name from disabling in nwam) // zonecfg -z oibld create set autoboot=true set zonepath=/zones/oidev/oibld set ip-type=exclusive add net set physical=e1000g1 end exit * Install the zone: ''zoneadm -z oibld install'' === Initialize the zone's basic local config === * Make the zone "ready": ''zoneadm -z oibld ready'' * Populate the zone's sysidcfg: cat < /zones/oidev/oibld/root/etc/sysidcfg terminal=xterms network_interface=PRIMARY {dhcp protocol_ipv6=no} security_policy=none name_service=NONE nfs4_domain=dynamic timezone=UTC root_password=NP EOF * Boot the zone with: ''zoneadm -z oibld boot'' * Log into the zone with: ''zlogin -C oibld'' * Change the root password to blank (by hitting return twice for password) === Set up DNS === * Populate /etc/resolv.conf and chown it to netadm:netadm * Change the hosts line in /etc/nsswitch.conf (add "dns" after "files") ==== Other zone operations ==== === Removing a zone === * Shut down the zone my-zone using one of the following methods. \\ // The zoneadm shutdown method is preferred // * Using zoneadm: \\ ''global# zoneadm -z my-zone shutdown'' \\ ''my-zone'' * Using zlogin: \\ ''global# zlogin my-zone shutdown'' \\ ''my-zone'' * Remove the root file system for my-zone. \\ ''global# zoneadm -z my-zone uninstall -F'' \\ // the -F option to force the action generally isn't required // * Delete the configuration for my-zone: \\ ''global# zonecfg -z my-zone delete -F'' \\ // the -F option to force the action generally isn't required. // * List the zones on the system, to verify that my-zone is no longer listed. \\ ''global# zoneadm list -iv'' * You will see a display that is similar to the following:ID NAME STATUS PATH BRAND IP 0 global running / solaris shared \\ // Links: [[:tech:start|Tech Info]] ... [[:mantis:start|Mantis Area]] //